RG Tech Support Phone Lines Down
Incident Report for Real Geeks
Resolved
This incident has been resolved.
Posted Apr 22, 2024 - 12:03 CDT
Identified
Zendesk phones are experiencing a technical issue and we are unable to take inbound calls and most outbound calls are failing. We will be working via email until this is resolved, no ETA currently.
Posted Apr 22, 2024 - 10:40 CDT