Setting up Traffic Blaster is currently not possible
Incident Report for Real Geeks
Resolved
This incident has been resolved.
Posted Nov 08, 2023 - 16:29 CST
Update
The issue with Google Adwords API has gone away. Traffic Blasts may be created again.
Posted Nov 08, 2023 - 16:28 CST
Investigating
Due to an issue with Google Adwords, setting up Traffic Blaster is currently not possible. We are investigating the issue.
Posted Nov 08, 2023 - 16:07 CST
This incident affected: Real Geeks CRM (Traffic Blaster).