Lead Manager CRM Down
Incident Report for Real Geeks
Resolved
This incident has been resolved.
Posted Apr 03, 2024 - 17:25 CDT
Update
We are continuing to investigate this issue.
Posted Apr 03, 2024 - 17:23 CDT
Investigating
We are currently investigating this issue.
Posted Apr 03, 2024 - 17:23 CDT
This incident affected: Real Geeks CRM (Lead Manager).