Slow site performance.

Incident Report for Real Geeks

Resolved

This incident has been resolved.
Posted May 07, 2025 - 19:29 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 07, 2025 - 11:16 CDT

Investigating

We are investigating reports that some Real Geeks websites are loading slowly.
Posted May 07, 2025 - 09:50 CDT
This incident affected: Real Geeks IDX Websites (Website Content).