Duplicate properties appearing in search results
Incident Report for Real Geeks
Resolved
we have corrected the issue causing duplicate properties in search results
Posted Jul 30, 2021 - 00:49 CDT
Investigating
We are currently investigating a problem with properties appearing in search results multiple times.
Posted Jul 29, 2021 - 19:40 CDT
This incident affected: Real Geeks IDX Websites (Property Data (RETS/IDX and Web API)).