Increased website load times
Incident Report for Real Geeks
Resolved
This incident has been resolved.
Posted Jun 09, 2023 - 12:34 CDT
Monitoring
We have identified the issue and a fix has been implemented. Site performance is returning to normal.
Posted Jun 09, 2023 - 11:31 CDT
Investigating
We are investigating an issue that is causing increased website load times.
Posted Jun 09, 2023 - 11:11 CDT
This incident affected: Real Geeks IDX Websites (Website Content, Seller Valuation Tool).