DB maintenance - downtime for accounts.realgeeks.com and home.realgeeks.com
Incident Report for Real Geeks
Resolved
This incident has been resolved.
Posted Apr 20, 2021 - 22:46 CDT
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 20, 2021 - 22:30 CDT